TLS v1.2 requirement

On the 9th of March, 2016 we turned off support for HTTPS negotiation over earlier versions of TLS, specifically versions 1.0 and 1.1. Inevitably, we broke support for implementations running on early versions of OpenSSL and JRE.